The Android community has come to use Rx pretty heavily but surprisingly there hasn't been any one convention that's won, when it comes to how we name our functions that return Observables. getUser(), user(), userUpdates() ? In this mini-episode dutifully does the yak-shaving for you and discusses what some options are and what the community has been gravitating towards.


Enjoy.


Shownotes

yak-shaving

Upday's convention:

Florina's tweet
Upday's blog post - Reactive Frustrations 1

Options
// option 1
fun getUser(): Single
// yuck

// option 2
fun user(): Observable
// but what does this mean?

// option 3
fun user(): Single
fun userUpdates(): Observable
// or
fun userStream(): Observable
// this is looking good

// option 4 (upday style)
fun userOnce(): Single
fun userStream(): Observable
fun userOnceAndStream(): Observable

Stay tuned for a future episode, where we discuss more details and more complicated cases to handle (like emitting a list of user, policies for fetching the first user as quickly as possible etc.).


Also #FinishNotation.


Sponsors 🙏

sentry.io - Your code is broken. Let’s fix it together - https://sentry.io/for/android/

Contact

Discord chat or @fragmentedcast or our Youtube channel
@donnfelker and donnfelker (on Instagram)
@kaushikgopal and kaushikgopal (on Instagram)

Twitter Mentions